Sunday, May 01, 2016

Commodore VIC-20

The famous VIC-20. Predecessor to the Commodore 64, introduced in 1980 and thus being the very first affordable (US$300,-) colour computer.  Almost three million units were sold at the time, so they are still not very rare.
The unit I got (for €40,-) is in pretty good condition. The case has some inevitable yellow marks, caused by the reaction of UV light with the flame-retardand in the plastic. Something that could be removed (just google for 'RetrOBright')  but I think I'll just leave it like it is and not risk damaging the plastic.
The unit came without any cables, so the first step will be to find out how to connect the monitor. As always, this information is easy to be found. I found a complete overview on Retro Isle this time.
The video is on the 5-pin DIN plug, 2 = GND, 4= Video. 

Unfortunately it does not seem to work.
My small LCD monitor (that works fine with my TRS-80 and Acorn Electron) says 'no signal'. When measuring the video signal on the outside and on the board itself using an oscilloscope it looks good. But even adjusting the output level to the max does not solve the issue.
Just to be sure there is something wrong with it I connected it to the flatscreen television in the living room, only to find that it actually does work....
Looking into this issue I found several references to the fact that the video signal of the VIC is really bad, which did not really matter in those days since the standard television and monitor was pretty tolerant, but is a problem for our modern, all digital, LCD screens.
On the 'Denial WIKI' there are a few suggestions on how to improve video output which might be worth trying.